Во многих корпоративных сетях имеется больше одной подсети. Это делается из соображений безопасности, т.к. таким образом легче контролировать трафик между несколькими подразделениями, предоставляя только тот доступ, который нужен подразделению. Как можно заметить, роутеры не могут порадовать изобилием свободных портов (в отличие от коммутаторов), поэтому приходится как-то выкручиваться.

Secondary IP

На интерфейс роутера можно назначить больше одного ip адреса, но это является не практичным и не безопасным решением, когда надо разделить ресурсы компании на разные подсети.

Router & dot1Q

dot1Q – это модифицированное название стандарта IEEE 802.1Q (dot в переводе на русский – точка). Этот стандарт определяет работу Virtual LAN (VLAN), в том числе и тегированные фреймы (которые “ходят” через trunk порты).

Router on a stick (Роутер на палочке) – это название топологии сети, где роутер физически подключен к сети только одним линком (проводом), при этом обслуживает несколько подсетей. Топология реализуется благодаря тому, что единственный имеющийся линк является trunk-ом и может различать фреймы из разных vlan, таким образом для каждого vlan создается свой подинтерфейс.

Общая информация

Packet Tracer version: 6.2.0

Рабочий файл: скачать

Тип: Теория и практика

Версия файла: 2.0

Уже получили: 45 пользователей


Часто задаваемые вопросы

Получить достижение

Код активации можно получить выполнив практическое задание

Achievement

Уже получили 45 пользователей


Начальные данные

Все “манипуляции” можно осуществлять только при помощи PC0 (либо с других PC в сети).

В данной практической работе сеть уже спланирована, большая часть настроена (рисунок 3.1). На всем сетевом оборудовании настроен telnet-сервер, пароль – cisco123. VLAN уже распределены по всем портам, согласно схеме, там же представлена вся адресация. Например, на PC0 вы можете видеть “.10”, это означает, что он имеет ip адрес 10.13.1.10. Коммутаторы относятся к подсети 10.13.1.0/28.

Рисунок 3.1 Схема сети из практической работы
Рисунок 3.1 Схема сети из практической работы


Список VLAN-ов:

  • VLAN 20 – 10.13.1.0/28
  • VLAN 21 – 10.21.1.0/25
  • VLAN 80 – 10.88.2.0/23
  • VLAN 122 – 10.99.1.0/30

Цели

  1. Познакомиться с функцией secondary ip.
  2. Реализовать топологию “Роутер на палочке”. Проверить маршрутизацию.

Выполнение

  1. Познакомиться с функцией secondary ip

    К сожалению, Packet Tracer не поддерживает функцию secondary ip, т.е. практического применения здесь не будет.

    Функция secondary ip добавляет ip адрес на интерфейс при помощи команды ip address <ip адрес> <маска> secondary. Если бы Packet Tracer поддерживал эту функцию, настройка выглядела бы так.

     r1(config)#interf fastEthernet 0/0
     r1(config-if)#ip add 10.88.2.1 255.255.254.0 secondary
     r1(config-if)#ip add 10.21.1.1 255.255.255.128 secondary
     r1(config-if)#ip add 10.99.1.1 255.255.255.252 secondary
    

    Команда show ip interface brief показывает только основной ip адрес. Для того чтобы посмотреть настроена ли функция secondary ip можно использовать одну из команд: во первых show running-config, а так же show ip interface <номер интерфейса>. Если бы Packet Tracer поддерживал эту функцию, эти команды выглядели бы так.

     r1#sh runn
     Building configuration...
     
     Current configuration : 665 bytes
     !
     version 12.4
     ...
     !
     interface FastEthernet0/0
      ip address 10.13.1.1 255.255.255.240
      ip add 10.88.2.1 255.255.254.0 secondary
      ip add 10.21.1.1 255.255.255.128 secondary
      ip add 10.99.1.1 255.255.255.252 secondary
      duplex auto
      speed auto
     !
     ...
     r1#sh ip interf fa0/0
     FastEthernet0/0 is up, line protocol is up (connected)
       Internet address is 10.13.1.1/28
       Broadcast address is 255.255.255.255
       Address determined by setup command
       MTU is 1500 bytes
       Helper address is not set
       Directed broadcast forwarding is disabled
       Secondary address 10.88.2.1/23
       Secondary address 10.21.1.1/25
       Secondary address 10.99.1.1/30
       Outgoing access list is not set
       Inbound  access list is not set
       Proxy ARP is enabled
       ...
    
  2. Реализовать топологию “Роутер на палочке”. Проверить маршрутизацию

    Для того что бы реализовать топологию “Роутер на палочке”, между роутером и коммутаторм должен быть trunk. Выполним соответствующую настройку на коммутаторе, который “смотрит” на r1 интерфейсом Fa0/23. Вся настройка выполняется с PC0.

     PC>telnet 10.13.1.14
     Trying 10.13.1.14 ...Open
     
     
     User Access Verification
     
     Password: 
     sw-1#conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     sw-1(config)#interf fa 0/23
     sw-1(config-if)#switchport mode trunk 
     
     sw-1(config-if)#switchport trunk allowed vlan all 
     sw-1(config-if)#exit
     sw-1(config)#exit
     sw-1#sh interf trunk
     Port        Mode         Encapsulation  Status        Native vlan
     Fa0/23      on           802.1q         trunking      1
     Fa0/24      on           802.1q         trunking      1
     
     Port        Vlans allowed on trunk
     Fa0/23      1-1005
     Fa0/24      1-1005
     
     Port        Vlans allowed and active in management domain
     Fa0/23      1,20,21,80,122
     Fa0/24      1,20,21,80,122
     
     Port        Vlans in spanning tree forwarding state and not pruned
     Fa0/23      1,20,21,80,122
     Fa0/24      1,20,21,80,122
    

    Теперь коммутатор может отправлять тегированные фреймы в сторону r1. Пришло время настраивать r1.

    Для начала надо создать виртуальный интерфейс (далее подинтерфейс, subinterface), делается это при помощи команды interface <имя, номер интерфейса>.<номер подинтерфейса>. номер подинтерфейса может быть любым от 0 до 4294967295, но чаще всего, сетевые инженеры, указывают номер vlan к которому принадлежит этот subinterface, так конфигурация становится более понятной.В режиме настройки этого subinterface надо указать к какому vlan он принадлежит, при помощи команды encapsulation dot1Q <номер vlan>. После настройки encapsulation можно указывать ip адрес. Создадим четыре subinterface, один из которых будет лишним.Вся настройка выполняется с PC0. Subinterface для vlan 20 уже преднастроен, поэтому мы можем подключиться по telnet.

     PC>telnet 10.13.1.1
     Trying 10.13.1.1 ...Open
     
     
     User Access Verification
     
     Password: 
     r1#conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     r1(config)#interf fa 0/0.?
       <0-4294967295>  FastEthernet interface number
     r1(config)#interf fa 0/0.21
     r1(config-subif)#encapsulation dot1Q ?
       <1-1005>  IEEE 802.1Q VLAN ID
     r1(config-subif)#encapsulation dot1Q 21
     r1(config-subif)#ip add 10.21.1.1 255.255.255.128
     r1(config-subif)#interf fa 0/0.80
     r1(config-subif)#encapsulation dot1Q 80
     r1(config-subif)#ip add 10.88.2.1 255.255.254.0
     r1(config-subif)#interf fa 0/0.122
     r1(config-subif)#encapsulation dot1Q 122
     r1(config-subif)#ip add 10.99.1.1 255.255.255.252
     r1(config-subif)#
     r1(config-subif)#interf fa 0/0.133
     r1(config-subif)#encapsulation dot1Q 133
     r1(config-subif)#ip add 1.1.1.1 255.255.255.0
    

    Теперь посмотрим, что выдаст нам команда show ip interface brief.

     r1#sh ip interf br
     Interface              IP-Address      OK? Method Status                Protocol
      
     FastEthernet0/0        unassigned      YES unset  up                    up
      
     FastEthernet0/0.20     10.13.1.1       YES manual up                    up
      
     FastEthernet0/0.21     10.21.1.1       YES manual up                    up
      
     FastEthernet0/0.80     10.88.2.1       YES manual up                    up
      
     FastEthernet0/0.122    10.99.1.1       YES manual up                    up
      
     FastEthernet0/0.133    1.1.1.1         YES manual up                    up
      
     FastEthernet0/1        unassigned      YES unset  administratively down down
      
     Vlan1                  unassigned      YES unset  administratively down down
    

    Обратите внимание, что на интерфейсе Fa0/0 не настроена инкапсуляция, но при этом он относится к vlan 1. Тут надо вспомнить как работает trunk. В каждом trunk можно указать лишь один vlan, который будет ходить без тэга, по умолчанию это vlan 1. Таким образом весь не тегированый трафик попадает на Fa0/0, а тегированный трафик попадает на соответствующий vlan-у subinterface.

    Subinterface-ы рассматриваются роутером как отдельные, самостоятельные интерфейсы и не смотря на то что они “виртуальные”, настраиваются они аналогично “физическим” интерфейсам. Важное замечание, если физический интерфейс выключен, то и все subinterface-ы, относящиеся к нему, тоже будут выключены.

    Теперь удалим лишний интерфейс который мы создали – FastEthernet0/0.133. Делается это при помощи команды no <аргумент> (это очень “мощная команда”, если вы еще не поняли как она работает, просто пользуйтесь ей чаще, редактируйте конфигурацию и тут же ее удаляйте при помощи no).

     r1(config)#no interf fa 0/0.133
     r1(config)#exit
     r1#sh ip interf br
     Interface              IP-Address      OK? Method Status                Protocol
      
     FastEthernet0/0        unassigned      YES unset  up                    up
      
     FastEthernet0/0.20     10.13.1.1       YES manual up                    up
      
     FastEthernet0/0.21     10.21.1.1       YES manual up                    up
      
     FastEthernet0/0.80     10.88.2.1       YES manual up                    up
      
     FastEthernet0/0.122    10.99.1.1       YES manual up                    up
      
     FastEthernet0/1        unassigned      YES unset  administratively down down
      
     Vlan1                  unassigned      YES unset  administratively down down
    

    Самое время проверить маршрутизацию. Для начала проверим доступность некоторых устройств с r1.

     r1#ping 10.99.1.2
    
     Type escape sequence to abort.
     Sending 5, 100-byte ICMP Echos to 10.99.1.2, timeout is 2 seconds:
     .!!!!
     Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/3 ms
     
     r1#ping 10.21.1.90
     
     Type escape sequence to abort.
     Sending 5, 100-byte ICMP Echos to 10.21.1.90, timeout is 2 seconds:
     .!!!!
     Success rate is 80 percent (4/5), round-trip min/avg/max = 0/1/3 ms
    

    С помощью команды tracert изучим путь, от PC1 до CiscoLearning, рисунок 3.2.

    Рисунок 3.2 Traceroute от ПК5 до Server0
    Рисунок 3.2 Traceroute от PC1 до CiscoLearning


    Первым “прыжком” (hop), PC1 указывает r1 (10.21.1.1), а вторым CiscoLearning (10.99.1.2). Очень важно представлять какой путь проходят данные.


    Еще раз напоминаю о важности настройки gateway (шлюза по умолчанию). В данной практической работе все было настроено. Ради тренировки настройте gateway на sw-1 и sw-2, после чего вы сможете подключаться к ним с любого компьютера.

Общая информация

Packet Tracer version: 6.2.0

Рабочий файл: скачать

Тип: Самостоятельная работа

Версия файла: 2.0

Уже получили: 45 пользователей


Часто задаваемые вопросы

Получить достижение

Код активации можно получить выполнив практическое задание

Achievement

Уже получили 45 пользователей


Начальные данные

Все “манипуляции” можно осуществлять только при помощи PC0. Пароль от оборудования cisco123, подключаться используя telnet. Для доступа на сетевое оборудование, используйте адресацию представленную на схеме, например, sw-1 имеет адрес 10.7.7.7, a r1 – 10.7.7.11

Рисунок 3.3 Схема Лабораторки
Рисунок 3.3 Схема Лабораторки


Задание

Настроить оборудование так, что бы результат трасировки с PC1 до PC2 был как на рисунке 3.4 (10.17.1.133 – PC2).

Рисунок 3.4 Результат выполнения лабораторки
Рисунок 3.4 Результат выполнения лабораторки
  1. Настроить PC1:

    1. Назначить ip адрес 10.14.1.10/25. Не забываем про gateway. Какой? Догадаетесь сами.
  2. Настроить PC2:

    1. Назначить ip адрес 10.17.1.133/25. Не забываем про gateway. Какой? Догадаетесь сами.
  3. Настроить sw-1:

    1. Создать vlan 14 (VLAN14), vlan 15 (VLAN15), vlan 16 (VLAN16) и vlan 17 (VLAN17). В скобках представлены имена, которые обязательно надо добавить.
    2. Перевести порты Fa0/1, Fa0/2, Fa0/3 режим trunk.
    3. Перевести порт Fa0/24 в режим access, vlan 14.
    4. Перевести порт Fa0/23 в режим access, vlan 17.
  4. Настроить r1:

    1. Создать subinterface для vlan 14. Назначить ему ip адрес 10.14.1.1/25.
    2. Проверить доступность PC1.
    3. Создать subinterface для vlan 15. Назначить ему ip адрес 10.15.1.1/30.
    4. Добавить маршрут к 10.17.1.128/25 через r2
  5. Настроить r2:

    1. Создать subinterface для vlan 15. Назначить ему ip адрес 10.15.1.2/30.
    2. Создать subinterface для vlan 16. Назначить ему ip адрес 10.16.1.1/30.
    3. Добавить маршрут к 10.14.1.0/25 через r1
    4. Добавить маршрут к 10.17.1.128/25 через r3
  6. Настроить r3:

    1. Создать subinterface для vlan 16. Назначить ему ip адрес 10.16.1.2/30.
    2. Создать subinterface для vlan 17. Назначить ему ip адрес 10.17.1.129/25.
    3. Проверить доступность PC2.
    4. Добавить маршрут по умолчанию(очень важно для достижения) через r2.
  7. Выполнить трасировку с PC1 до PC2. Сравнить результат с рисунком в задании.



ID: 146 Created: Oct 19, 2016 Modified Jan 16, 2017